Back
Degraded

Slowness on some pages

Started , resolved .

App
Resolved

The roll back of the release was successful, bringing the app to known stable state. Thank you for your patience.

Posted .
Updated

We have identified the cause to be a recent release, which we are now rolling back.

Posted .
Created

We are experiencing some slowness on pages. We are investigating the performance issues.

Posted .